Skype.com shows only openSUSE 12.1 32bit version rpm available. While it looks like outdated this rpm does work fine on openSUSE 12.3. All you have to do is download the rpm and install it using zypper (to resolve the dependencies). zypper in skype-4.1.0.20-suse.i586.rpm alsa-plugins-pulse-32bit

Skype needs the 32bit ALSA plugin for PulseAudio, so we specify that as well during installation.