If you’ve just set up apache and you try using the SSL feature, you’ll most probably get the following error:

Invalid command ‘SSLEngine’, perhaps misspelled or defined by a module not included

This is caused by mod_ssl not being enabled. mod_ssl comes bundled with the apache-common package but it is not enabled by default. To enable it execute the following: a2enmod ssl You may then restart apache; /etc/init.d/apache2 restart